< 返回上层

windows2012R2 IIS中ASP.NET网站提示.NET版本问题

2019-08-12 12:47:30 62次

目前这个问题出现在我们新安装系统2012R2后出现。我们新安装好了后,安装系统中的IIS和。net4.5这些后却发现建站出来的网站提示.NET版本不对。查看地址池这些都已经设置成4.0了的但还是不对的情况。

这里问题主要是出现在补丁上。一般新安装的windows2012R2都是基础镜像的文件。里面不包含了一些必要的补丁包。
直接安装的.NET是不能使用的,需要按照顺序分别安装KB2919442和KB2919355补丁,重启服务器即可。

报错截图
image.png

在服务器角色添加中我们可以看到我们的4.0是安装的。主要是KB2919355这个补丁。

提交成功!非常感谢您的反馈,我们会继续努力做到更好!

更多建议

这条文档是否有帮助解决问题?

没有帮助 有帮助

非常抱歉未能帮助到您。为了给您提供更好的服务,我们很需要您进一步的反馈信息:

在文档使用中是否遇到以下问题: