< 返回上层

Linux系统升级python3后yum失效的解决方法

2018-07-12 17:51:21 216次

因为yum使用python2,因此替换为python3后可能无法正常工作,继续使用原来系统的python2.6(我的系统的python原来版本). 因此修改yum配置文件


vim /usr/bin/yum

把文件头部的#!/usr/bin/python改成#!/usr/bin/python2.6保存退出即可.


但是,只是修改这些可能还不够,在我进行yum安装的时候,显示如下错误:


[yum install screen

 显示/usr/libexec/urlgrabber-ext-down错误,

打开/usr/libexec/urlgrabber-ext-down,跟前面一样,改为python2.6,完成。


提交成功!非常感谢您的反馈,我们会继续努力做到更好!

更多建议

这条文档是否有帮助解决问题?

没有帮助 有帮助

非常抱歉未能帮助到您。为了给您提供更好的服务,我们很需要您进一步的反馈信息:

在文档使用中是否遇到以下问题: